package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?((([a-z0-9])*[:]){1}|(([a-z0-9])*[.]){1}|(([0-9]){1,3}([.]|[:])){3}(([0-9]){1,3}[:]){1})([a-z]{2,5}|[0-9]{1,5})([.]([a-z0-9]){1,3})?(\/.*)?$`)
var str = `http://www.domain.com.hn:8080/callback`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}