# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?mi)
^
(?!
\h*
(?: [A-Z] \h* \. | ANSWER \h* : )
)
\h*
(?<question> \S .*? ) # (1)
\?? \h* \s* ^ \h* A \h* \. \h*
(?<A> .*? ) # (2)
\h*
\s*
(?:
^ \h* B \h* \. \h*
(?<B> .*? ) # (3)
\h*
(?:
\s* ^ \h* C \h* \. \h*
(?<C> .*? ) # (4)
\h*
(?:
\s* ^ \h* D \h* \. \h*
(?<D> .*? ) # (5)
\h*
(?:
\s* ^ \h* E \h* \. \h*
(?<E> .*? ) # (6)
\h*
)?
)?
)?
)?
\s* ^ \h* ANSWER \h* : \h*
(?<answer1> [A-F] ) # (7)
(?:
\h* , \h*
(?<answer2> [A-F] ) # (8)
)?
"""
test_str = ("Linux is\n"
"A. A Graphic Software\n"
"B. A Driver\n"
"C. A Line Controller Software\n"
"D. An Operating System\n"
"ANSWER: D\n"
"Which feature helps in compress and contain the collection of files in to one\n"
"A. Zip\n"
"B. Shortcut\n"
"C. Icon\n"
"D. Extract\n"
"ANSWER: A\n\n"
"What is php?\n\n"
"A. Php is a language.\n\n"
"B. Php creates HTML.\n\n"
"C. Php is fun.\n\n"
"D. none of these.\n\n"
"ANSWER: D\n\n\n\n"
"Which is YII-2?\n\n"
"A. Framework.\n\n"
"B. Tool.\n\n"
"C. None of these\n\n"
"ANSWER: A,B")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.