re = /(?:youtube\.com\/(?:[^\/]+\/.+\/|(?:v|e(?:mbed)?)\/|.*[?&]v=)|youtu\.be\/)([^"&?\/\s]{11})/m
str = 'https://www.youtube.com/watch?v=dQw4w9WgXcQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end