#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^a{3}$"
Local $sString = "b" & @CRLF & _
"a" & @CRLF & _
"aa" & @CRLF & _
"aaa" & @CRLF & _
"aaaa" & @CRLF & _
"aaaaa" & @CRLF & _
"aaaaaa"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")