$re = '/(?<=\s|^|\b)(?:[-\'.%$#&\/]\b|\b[-\'.%$#&\/]|[A-Za-z0-9]|\([A-Za-z0-9]+\))+(?=\s|$|\b)/';
$str = 'apple(s)
(else?)
$13.30
This string\'s is a good example of situation I\'ll fail to match - due to punctuations being all over the place.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);