re = /(?<=\s|^|\b)(?:[-'%$#&\/]\b|\b[-'%$#&\/]|\d*\.?\d+|[A-Za-z0-9]|\([A-Za-z0-9]+\))+(?=\s|$|\b)/
str = 'apple(s)
(else?)
$13.30
This string\'s is a good example of situation I\'ll fail to match - due to punctuations being all over the place.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end