package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[\u0E01-\u0E2E]+$`)
var str = `ฟก`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}