const regex = /(?<=\d)(?=[A-Za-z])|(?<=[A-Za-z])(?=\d)|(?<=[a-z])(?=[A-Z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d)(?=[A-Za-z])|(?<=[A-Za-z])(?=\\d)|(?<=[a-z])(?=[A-Z])', 'gm')
const str = `foo
fooBar
foo123
123Foo
fooBar123
foo123Bar
123FooBar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}