$re = '/Lorem Ipsum!?(?=\s|$)/';
$str = 'Lorem Ipsum! Lorem Ipsumus maximus Mirellius.Lorem Ipsum!eee Lorem Ipsum! eee';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);