re = /(\#)([a-zA_Z0-9]*)(\#)(\s{1})(.*)\n{1}(\s{2})([a-zA_Z0-9]*)(\s{3})(.*)/
str = '#1# OPTION 1
2 OPTION 2
3 OPTION 3
4 OPTION 4
5 OPTION 5
6 OPTION 6
7 OPTION 7
8 OPTION 8
9 OPTION 9
10 OPTION 10
100 OPTION 100
1000 OPTION 1000
[REPLACEALL](\\#)([a-zA_Z0-9]*)(\\#)(\\s{1})(.*)\\n{1}(\\s{2})([a-zA_Z0-9]*)(\\s{3})(.*)[WITH]$6$2$8$5
#$7#$4$9'
subst = '$6$2$8$5\\n#$7#$4$9'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result