package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+(\+\d)*`)
var str = `1+2
3
1+22+3
+1+2
1+
a+1+b+c
12+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}