package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)gif`)
var str = `Gif
gif
GIF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}