#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\$?[A-Z]+\$?\d+(?::\$?[A-Z]+\$?\d+)?(?:,\s*(?:\$?[A-Z]+\$?\d+(?::\$?[A-Z]+\$?\d+)?))*$"
Local $sString = "E5" & @CRLF & _
"AA55:E5" & @CRLF & _
"DD5555:DDD55555, E5, F5:AA55" & @CRLF & _
"$F7:$G$7" & @CRLF & _
"" & @CRLF & _
"bis_document_id" & @CRLF & _
"PCR1MM_YPCVolume" & @CRLF & _
"sheet_error7" & @CRLF & _
"blahE5" & @CRLF & _
"training_A1" & @CRLF & _
"myNameIsGeorgeJR" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")