import re
regex = re.compile(r"^interface GigabitEthernet1\/0\/[0-9](?=(?:(?!\ninterface GigabitEthernet1\/0\/[0-9])[\s\S])*switchport mode access)", flags=re.MULTILINE)
test_str = ("interface GigabitEthernet1/0/1\n"
" description abc\n"
" bla\n"
" switchport mode access\n"
" xyz\n"
" abc\n"
"interface GigabitEthernet1/0/2\n"
"interface GigabitEthernet1/0/3\n"
" xyz\n"
" abc\n"
"interface GigabitEthernet1/0/4\n"
" description Test\n"
" switchport mode access\n"
" xyz\n"
" abc\n"
"interface GigabitEthernet1/0/5\n"
" description")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")