import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:EXPERIENCE|Employment experience)\\s*\\n(.*?)\\n(?:Skills|Education)";
final String string = "xyz \n"
+ "66 Chetwynd Road \n"
+ "UK \n"
+ " \n"
+ "Phone - 070040040040 \n"
+ "Email - a18@hotmail.co.uk \n"
+ "PERSONAL PROFILE \n"
+ "I am an energetic, hardworking individual who has developed a responsible approach to any \n"
+ "task I undertake or problem I’m presented with. With previous experience in both customer \n"
+ "service and administration, I can skillfully work with others and help with situations I am \n"
+ "faced with in a calm collective manner. \n"
+ "EXPERIENCE \n"
+ "Play Centre \n"
+ "HOST (September 2021- Present) \n"
+ "▪ Working well under pressure, making decisions quickly and strategically \n"
+ "▪ Problem -solving and using initiative \n"
+ " \n"
+ "xyz center \n"
+ "Sales Assistant (November 2020 -January 2020) \n"
+ "▪ Interacted with customers ensuring service was welcoming and helpful. \n"
+ "▪ Responded to any queries \n"
+ " \n"
+ " \n"
+ "Health & Wellness Club - Work Experience \n"
+ "Staff - (January 2020 - February 2020) \n"
+ "▪ Welcomed members into the gym \n"
+ "▪ Ensured all equipment was safe and clean before it was used by members \n"
+ " \n"
+ "EDUCATION \n"
+ "September 2021 -2022 \n"
+ "University College ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}