#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<pool>([A-Z])\2{0,2})(?<number>(100|[1-9]\d?))$"
Local $sString = "A1" & @CRLF & _
"AA2" & @CRLF & _
"AAA3" & @CRLF & _
"B100" & @CRLF & _
"CC7" & @CRLF & _
"ABC1234" & @CRLF & _
"A12" & @CRLF & _
"AA21" & @CRLF & _
"AAA36" & @CRLF & _
"B57" & @CRLF & _
"CC76" & @CRLF & _
"ABC1234" & @CRLF & _
"UVW1" & @CRLF & _
"ABC2" & @CRLF & _
"AAAA4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")