#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)(?:(?:https?|ftp|file):\/\/|www\.|ftp\.)(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[-A-Z0-9+&@#\/%=~_|$?!:,.])*(?:\([-A-Z0-9+&@#\/%=~_|$?!:,.]*\)|[A-Z0-9+&@#\/%=~_|$])"
Local $sString = "www.test" & @CRLF & _
"www.test.com" & @CRLF & _
"http://fruit.loops" & @CRLF & _
"ftp://my.test.com" & @CRLF & _
"https://google.com" & @CRLF & _
"" & @CRLF & _
"Sample text for testing:" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"0123456789 +-.,!@#$%^&*();\\/|<>\"\'" & @CRLF & _
"12345 -98.7 3.141 .6180 9,000 +42" & @CRLF & _
"555.123.4567 +1-(800)-555-2468" & @CRLF & _
"foo@demo.net bar.ba@test.co.uk" & @CRLF & _
"www.demo.com http://foo.co.uk/" & @CRLF & _
"http://regexr.com/foo.html?q=bar" & @CRLF & _
"fa moo moo.com fa moo moo.co.uk da moo[dot]com doo moo [dot] com and not moo.c0m but do moo.cc and moo.co0uk" & @CRLF & _
"www.example.com/hello.html?ho#t-t_hy sdf http://regexr.com/" & @CRLF & _
"http://localhost:5000/#/tl/myteam" & @CRLF & _
"www.home4.com" & @CRLF & _
"http://localhost:5000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")