$re = '/^\+?[0-9-\.][0-9\s-\.]*/m';
$str = '+0123456789
+ 012345678
0 123 45678
+0 12345678';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);