re = /^(?:[^([{,;=]+|(?<=OPTIONAL)\()+/m
str = 'x OPTIONAL() y z(..., ...)
x y z(..., ...)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end