$re = '/^(?!(https?:\/\/)(arizona.box.com|docs.google.com|dropbox.com|www.dropbox.com|emailarizona-my.sharepoint.com|events.trellis.arizona.edu)).*/m';
$str = 'http://www.arizona.edu
https://arizona.box.com/test
https://docs.google.com/test
https://www.dropbox.com/blahblahblah
http://arizona.box.com
http://www.asu.edu';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);