package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`From:.*?<`)
var str = `From: John Smith <johnsmith@gmail.com> Date: Fri, 12 Jan 2018 13:56:47 -0500 Message-ID: <CAOiWwegyRC+FE75Ezw3AxiCbNegswuQz8eLCCO0=hFGsLA@mail.gmail.com> Subject: test email To: bobsmith@yahoo.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}