re = /From:[^<]*</
str = 'From: John Smith <johnsmith@gmail.com> Date: Fri, 12 Jan 2018 13:56:47 -0500 Message-ID: <CAOiWwegyRC+FE75Ezw3AxiCbNegswuQz8eLCCO0=hFGsLA@mail.gmail.com> Subject: test email To: bobsmith@yahoo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end