# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=\D*\d)[\w\/-]{7,}"
test_str = ("Te poniższe bym chciał:\n"
"ZOC1050056\n"
"23639583\n"
"GL20/11878/17\n"
"20700246365_1\n"
"WR50/11349/17\n"
"PL201709120448\n"
"pl2017072600414\n"
"1054332/1133787\n"
"H201709201932-01\n"
"143392/DLS/17 KO/455/17\n\n"
"a to już false positives:\n\n"
"bardzodlugieslowo\n"
"niechcetegoo?")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.