package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<data>.+?)(\:\:|$)`)
var str = `On:e::tw:o::thr$ee `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}