re = /\d{4}-[01]\d-[0-3]\dT[0-2]\d:[0-5]\d:[0-5]\d([+-][0-2]\d:[0-5]\d|Z)$/
str = '2008-03-01T13:00:00Z'
# Print the match result
str.match(re) do |match|
puts match.to_s
end