$re = '/\S*@\S*\s?/';
$str = 'abc user@xxx.com 123 any@www foo @ bar 78@ppp @5555 aa@111';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;