$re = '/^[-a-zA-Z0-9!$%^&*()_+|~=`{}\[\]:";\'<>?,.\/]{50,}$/';
$str = '%242a%2410%24mbh0scotTihKwL69eKwVBuSoAShai4Qo8yY0HLPRlh0Pq0ospfAcm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);