use strict;
my $str = 'pshow
Port | Name |Status| Reservation
1 | Fan | ON |
2 | Clim | OFF| mofa
>
����������"
Synaccess Inc. Telnet Session V6.2.
pshow
>
Port| Name |status| Reservation |RB Timer
----+----------------+------+----------------+--------
1| Outlet1| OFF| | ON
2| Outlet2| ON | mofa| OFF
3| Outlet3| ON | | OFF
4| Outlet4| OFF| | OFF
5| Outlet5| ON | | OFF
6| Outlet6| ON | | OFF
7| Outlet7| OFF| | OFF
8| Outlet8| ON | | OFF
9| Outlet9| ON | | OFF
10| Outlet10| OFF| | OFF
AC current draw 1: 0.05. Max detected 0.78 Amps.
Temperature Probe is not installed
>';
my $regex = qr/\s{2,3}(\d+)\|\s{8,9}(\w+)\|\s{3}(ON\s|OFF)\|(\s+|\s+\w+)\|\s{5}(ON\s|OFF)\n|\s{3}(\d)\s\|\s+(\w+)\s+\|\s+(ON\s|OFF)\|(\s{2}\n|.\w+)|AC current draw\s(\d)\:\s(\d\.\d{2})|Max detected\s(\d\.\d{2})/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}