#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([\:][\/]{0,2})[\w\-]+([\@]|[\.])?([\w\-]+[\.]){0,}([\w\-]+)?([\:][\d]+)?[\/]?"
Local $sString = "https://user_test-teste@regex101.com:80/" & @CRLF & _
"http://localhost:80/" & @CRLF & _
"https://tools.ietf.org/html/rfc3986#page-7" & @CRLF & _
"https://translate.google.com.br/#en/pt/that%20what" & @CRLF & _
"https://www.google.com.br/search?client=firefox-b&biw=1920&bih=1001&q=overload+inexistent+property+php&oq=overload+inexistent+property+php&gs_l=psy-ab.3..33i22i29i30k1.36919.57166.0.57324.38.36.2.0.0.0.682.3958.14j18j5-1.33.0....0...1.1.64.psy-ab..3.27.3324...0j35i39k1j0i131k1j0i67k1j0i10k1j0i22i30k1j33i160k1j33i21k1.m5dBRh4nQ-I"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")