re = /^(?!.*?blues).*?roadhouse.*$/mi
str = 'roadhouse
My roadhouse blues
Blues roadhouse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end