package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`123`)
var str = `[0-9]+`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}