re = /(?<=[A-Z])(\.)(?=[A-Z])|\./m
str = 'U.S.A is abbr x.y is not. But I.I.T. is also valid ABBVR and so is M.Tech, X.2, X., X.*'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end