use strict;
my $str = '<a href="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229.png"><img class="aligncenter wp-image-4054" src="http://www.mobil.hr/wp-content/uploads/2017/12/Screenshot_20171219-102229-563x1000.png" alt="" width="339" height="602" /></a>';
my $regex = qr/(<a([^>]*)>)(<img([^>]*)>)/ip;
my $subst = '<div>\\1 \\3</div>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";