$re = '/[a-z]{3,4}[0-9]?/';
$str = 'sss';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);