package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)BRU Weak Reference,[^,]+,\s+(?<bru_weak_reference>[^\s]+)`)
var str = `2018-12-07T14:41:55.974-0500: 358622.986: [SoftReference, 101571 refs, 0.0364703 secs]2018-12-07T14:41:56.010-0500: 358623.023: [WeakReference, 70294 refs, 0.0118371 secs]2018-12-07T14:41:56.022-0500: 358623.035: [FinalReference, 3823 refs, 0.0020774 secs]2018-12-07T14:41:56.024-0500: 358623.037: [PhantomReference, 271 refs, 993 refs, 0.0002618 secs]2018-12-07T14:41:56.024-0500: 358623.037: [BRU Weak Reference, 0.0008795 secs]
17G->12G(18G), 29.3445337 secs]
[Eden: 0.0B(920.0M)->0.0B(3408.0M) Survivors: 0.0B->0.0B Heap: 17.7G(18.0G)->12.4G(18.0G)], [Metaspace: 683138K->682699K(1738752K)]
[Times: user=56.84 sys=0.00, real=29.35 secs]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}