re = /^\b(a?)(b+)$/m
str = 'a
aba
ababba
ababbabbba
ababbabbbabbbba
ababbabbbabbbbabbbbba
abba
abbba
aa
abbaa
aabb
abababa
ababbba
abbaba
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end