# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(https?:\/\/[a-z0-9]+(?:[\-\.]{1}[a-z0-9]+)*\.[a-z]{2,6})(?=https?)(\S+)"
test_str = ("hi, this is your link (but this one is bad formatted and useless):\n\n"
"https://www.test.comhttps://app.test.com/a/b/c/5e20bed422e7880012ba8acc/next?param=1?locale=2\n\n"
"but there is a good link too:\n\n"
"https://app.test.com/a/b/c/5e20bed422e7880012ba8acc/next?param=1?locale=2\n\n"
"and there are also other irrelevant links:\n\n"
"http://www.google.com\n"
"http://test.test.com")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.