const regex = /\-\s([a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9]\.[a-zA-Z]*)|([a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9]\.[a-zA-Z.]{3,})\//gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\-\\s([a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9]\\.[a-zA-Z]*)|([a-zA-Z0-9][a-zA-Z0-9-]{1,61}[a-zA-Z0-9]\\.[a-zA-Z.]{3,})\\\/', 'gm')
const str = `24.06.2022 - Статьи на внешку - 6 - Челомова - vitok.ua.docx - Google Docs
https://real-vin.com/ispravlenie-prikusa-u-detej-plastinami-osobennosti
https://md-eksperiment.org/ru/post/20181030-protezirovanie-zubov-estetika-vidy-harakteristiki
https://md-eksperiment.org/ru/post/20181030-protezirovanie-zubov-estetika-vidy-harakteristiki
http://strichka.com/article/121746444
https://video.news.rin.ru/news_text/201741/
https://video.news.rin.ru/news/201741/
https://chdtu.edu.ua/ndi-chdtu/conferences-chdtu
https://strichka.com/article/121458075
https://obcity.gov.ua/2022/06/01/vseukrainska-stipendialna-programa-skyclinic-scholarship/
https://cikavosti.com/vazhn-e-prychyn-ne-terpet-bol-a-posetyt-stomatoloha-v-kyeve/
https://www.zaholovok.com.ua/u-chomu-plyusi-ta-osoblivosti-implantativ-straumann
https://zaholovok.com.ua/u-chomu-plyusi-ta-osoblivosti-implantativ-straumann
https://svaliava.rayon.in.ua/news/513952-tri-osnovni-sposobi-vipravlennya-prikusu-u-ditey
https://uzhgorod.net.ua/news/167547
https://www.uzhgorod.net.ua/news/167547
https://www.healthinfo.ua/articles/zdorovaia_gigiena/57875
https://kriptohit.ru/articles/chto-delat-esli-proglotil-breket.html
https://protocol.ua/ua/pochemu-otbelivanie-zubov-nado-provodit-u-stomatologa-kieve/
https://nuft.edu.ua/studentu/vazhliva-nformaczya/konkurs-za-inicziativi-naczionalnogo-memorialnogo-kompleksu
https://nuft.edu.ua/studentu/vazhliva-nformaczya/konkurs-za-inicziativi-naczionalnogo-memorialnogo-kompleksu
https://zhzh.info/news/2014-09-19-20583
https://www.poznavayka.org/anatomiya-i-meditsina/plyusy-i-minusy-ligaturnyh-breketov-stoit-li-ustanavlivat/
https://protocol.ua/ru/pochemu-otbelivanie-zubov-nado-provodit-u-stomatologa-kieve/
https://vz.ua/news/76398-bezopasna-li-odnomomentnaya-implantaciya-zubov
https://rusjev.net/2022/04/19/chto-takoe-otbelivanie-beyond/
https://shipovnik.ua/novosti/89279
https://eukraina.com/news/osobennosti_nesemnykh_zubnykh_protezov_kak_vybrat_podkhodjashhie/2022-02-19-26517
http://rusjev.net/2022/04/19/chto-takoe-otbelivanie-beyond/
https://healthinfo.ua/articles/zdorovaia_gigiena/57875
https://kharkovblog.info/pnews/implantaty-megagen-v-chem-osobennosti-i-preimushestva/
https://glavnoe.ua/news/n357084592-skolko-dlitsya-odnomomentnaya-implantaciya-zuba
https://onmedu.edu.ua/zaproshuiemo-prijnjati-uchast-u-scholarship-socialnij-programi-dlja-studentiv-ta-abituriientiv/
https://gorod.dp.ua/news/158085`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}