import Foundation
let pattern = #"(?<=Value=).*?(?=})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{[Response[attributes={Status=Success, action=Retrieve}; value=[NameList[attributes={PropertyName=Name}; value=[Names[attributes={}; value=[SimplePair[attributes={Key=-, Value=-}; value=[]], SimplePair[attributes={Key=Preferences, Value=Preferences}; value=[]], SimplePair[attributes={Key=&DEFAULT_PREFERENCE, Value=Default}; value=[]], SimplePair[attributes={Key=Profile, Value=Profile}; value=[]], SimplePair[attributes={Key=Duty Manager, Value=Duty Manager}; value=[]], SimplePair[attributes={Key=Mode User, Value=Mode User}; value=[]], SimplePair[attributes={Key=ModeDisplay Profile, Value=Mode Display Profile}; value=[]], SimplePair[attributes={Key=Mode Manager, Value=Mode Manager}; value=[]], SimplePair[attributes={Key=Professional Employees, Value=Professional Employees}; value=[]], SimplePair[attributes={Key=Scheduler, Value=Scheduler}; value=[]], SimplePair[attributes={Key=Super Access, Value=Super Access}; value=[]], SimplePair[attributes={Key=keeper, Value=keeper}; value=[]], SimplePair[attributes={Key=Manager, Value=Manager}; value=[]]]]]]]]]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)