$re = '/^[GTA]{5}GT[GTCA]{5}$/m';
$str = 'GTCTGGTGAGTT
GT
GTGTGGTGAGTT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);