package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[cb]at`)
var str = `cat bat hat cab`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}