$re = '/M\P{L}*?y\P{L}*?M\P{L}*?o\P{L}*?m\P{L}*?s\P{L}*?h\P{L}*?o\P{L}*?u\P{L}*?s\P{L}*?e/m';
$str = 'text 123 ->My Mom\'s house<- jidjio"
"bla bla ->My8Mo2ms231#43house<- bla bla"
"Test string ->MyMom\'s\' house<- further text" etc.
"wkashhasMdykMomLsfheoousssswQseBswenksd"
"textMy?M?om*s?*hou?*seorsomethingelse"
"thisIs3MĂ´yMomshouseEFSAcasw!"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);