// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\bcopy\.control\.(\w+)").unwrap();
let string = "copy() {
foundation.d.k(\"cloud control\")
this.is.a(context),reality, new point {\"copy.control.ZOOM_CONTROL\", \"copy.control.ACTIVITY_CONTROL\"},
context control";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}