package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w{3,})`)
var str = `Marie claude Bouraoui ds`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}