use strict;
my $str = '
';
my $regex = qr/^(?P<MAT_92>\w{2}[\-\ ]?\d{2}[\-\ ]?\d{2})|(?P<MAT_92_05>\d{2}[\-\ ]?\d{2}[\-\ ]?\w{2})|(?P<MAT_05_19>\d{2}[\-\ ]?\w{2}[\-\ ]?\d{2})|(?P<MAT_20_F>\w{2}[\-\ ]?\d{2}[\-\ ]?\w{2})$
/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}