use strict;
my $str = 'a:2:{s:4:"Test";s:29:"asdf\'a\\\' ;"serialize here;?"!";s:5:"test2";a:1:{s:4:"Test";s:15:"serialize here!";}}
';
my $regex = qr/\bs:\d+:"(?:(?!\bs:\d+).)*?serialize/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}