#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*\B@(?=\w{5,64}\b)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*.*"
Local $sString = "Hi @username how are you?" & @CRLF & _
"" & @CRLF & _
"Hi @username.how are you?" & @CRLF & _
"" & @CRLF & _
"😉@username." & @CRLF & _
"" & @CRLF & _
"And should not match email like this:" & @CRLF & _
"" & @CRLF & _
"Hi email to something@domain.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")