re = /.*\B@(?=\w{5,32}\b)[a-zA-Z0-9]+(?:_[a-zA-Z0-9]+)*.*/m
str = 'Hi @username how are you?
Hi @username.how are you?
😉@username.
And should not match email like this:
Hi email to something@domain.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end