import re
regex = re.compile(r"(var.*=)\s+(([\{\[][\n\r]+[\S\s]*?[\r\n]+[\}\]]([\r\n]+|\Z))|([^\n\r]*))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("var testmultiline = {\n"
" fizz = {\n"
" buzz = \"moo\"\n"
" }\n"
" buzz = {\n"
" buzz = \"moo\"\n"
" }\n"
"}\n\n\n"
"var test2 = null\n\n"
"var test3 = { still single line }\n\n"
"var randomportraits = load(globals.modfolder + \"/randomportraits/randomportraits.gd\").new()\n\n"
"<AddTo 0>\n"
"var races = {\n"
"HumanTest = {\n"
" skin = ['pale', 'fair', 'olive', 'tan'],\n"
" eyecolor = ['blue', 'green', 'brown', 'hazel', 'black', 'gray'],\n"
" haircolor = ['blond', 'red', 'auburn', 'brown', 'black'],\n"
" surname = names.humansurname,\n"
" description = \"Humans are a highly successful militaristic people whose members can be found throughout much of the world, their presence often receiving a mixed reception. Slavery is a common part of human society, viewed as a civilized form of alternative punishment, with many laws and businesses based around the concept. Because of this slave driven culture, you have found that humans tend to be the most widely accessible residents, servants, and slaves.\",\n"
" details = \"[color=aqua]Racial trait: Punishment expectations and praise lasts twice as long.[/color]\\n\\n[color=yellow]Stat potential: Strength - 5, Agility - 3, Magic - 2, Endurance - 4 [/color]\",\n"
" stats = {str_max = 5, \n"
" agi_max = 3, \n"
" maf_max = 2, \n"
" end_max = 4}\n"
"},\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")