import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "num:\\s*\\{\\s*(\\d+)\\s*\\}[\\s\\S]+?(?:ip\\S+:\\{\\s*([\\d\\.]+)\\s*\\}[\\s\\S]+?)[\\s\\S]+?(?:ip\\S+:\\{\\s*([\\d\\.]+)\\s*\\}[\\s\\S]+?)[\\s\\S]+?Uplink:\\s*\\{\\s*(\\d+)\\s*\\}[\\s\\S]+?Downlink:\\s*\\{\\s*(\\d+)\\}\\s*[\\s\\S]+xTime:\\{\\s*([\\s\\d-:]*?)\\s*\\}";
final String string = "{ num:{3025285000} }\n"
+ "{ ipadd:{iPadd:{iPv4add:{111.111.112.223} } } }\n"
+ "{ ipval:{iPadd:{13.100.1.11} } }\n"
+ "{ :{abc:{-} ddf:{-} mainVALUplink:{139161} mainVALDownlink:{6269538} kppacRR:{bbckdo} xTime:{2019-07-22 18:09:55 -03:00 } ppwo:{-} wwe:{-} iiurur:{qCI:{8} eerrr:{-} pppwie:{-} iiwww:{-} oouryru:{-} gg:{104} oosp:{-} pppsss:{-} } } }";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}